X86.CO.KR
100% 당첨매일매일 출석 도장 찍고 포인트 받아가세요
  • 일반모드 다크나이트모드 다크모드
    X86 통합검색
    Extra Form
    첨부
    CPU i7-8700k, 커피레이크, 8세대 
    보드/제품명 기가바이트 Z370 aorus gaming 7 (어로스 게이밍7) 
    그래픽 엔비디아 EVGA 1070 Ti, 라데온 기가바이트 RX 560 4기가 
    적용OS 하이시에라 10.13.4 (17E199) 
    기타칩셋  
    캡쳐파일/로그/증상설명 숙지 

     안녕하세요. 파컷 편집할 때 1070 ti가 생각보다 성능이 제대로 안나와서 어저께 라데온 RX 560을 구매하였습니다. RX560은 네이티브로 바로 잡힌다고 해서 1070 ti를 빼보고 설치해보니 바로 잡혔습니다. 듀얼모니터 출력에도 문제가 없었고요.


     이제 문제는 GTX 1070 ti를 같이 끼면서 발생합니다. 일단 제 메인보드 기가바이트 z370 aorus gaming 7은 PCI Express x16 슬롯이 3개 있는데요, 속도가 각각 다릅니다. 첫번째슬롯 : x16, 두번째슬롯 x8 입니다.


     기가바이트 커피레이크 최상급 보드로 알고 있었는데 두번째 슬롯까지 x16일 줄 알았는데 아니더라고요. asus z370 maximus x hero 같은 경우에는 두번째 슬롯까지 x16 이던데 좀 아쉬웠습니다...커맥 호환성이 기가바이트랑 좋다고 그래서 기가로 산건데...


     일단 저는 다른 ssd에 윈도우를 설치했고 윈도우 게이밍 환경에선 첫번째 슬롯에 1070 Ti가 장착되고 두번째 슬롯에 RX 560이 장착되는게 이상적이라고 생각했습니다. 두 개 모두 설치를 완료하고 저는 맥os에선 1070 Ti가 필요없었기 때문에 두번째 슬롯에 장착된 RX560에 두 개의 모니터를 장착해서 부팅해보았습니다. 근데 클로버 부트로더 이후에 맥os가 설치된 디스크를 부팅해도 화면출력이 안됩니다. 반대로 1번 슬롯에 장착된 1070 Ti에 두 개의 모니터를 장착해서 부팅해보니 정상적으로 부팅이 됩니다.


     

    시스템 정보에 들어가보니 RX 560 또한 인식이 되어있는 걸로 보였습니다. 모니터 한개만 RX 560에 물려보았으나 마찬가지로 화면출력이 안됩니다.


    https://x86.co.kr/tip/1030536

     위 링크를 참고해보니 nv_disable=1 를 클로버에서 설정하고 설치하신거 같습니다. 저도 똑같이 입력해보고 재부팅해보았으나 오히려 1070 ti, RX 560 모두 작동을 안합니다.


     고정관념을 깨고 속도가 좀 느린 두번째슬롯(x8)에 1070 ti를 장착하고 첫번째 슬롯(x16)에 RX 560을 장착하면 괜찮지 않을까(자리바꿈)하고 시도해보았습니다. 

    결과적으론 첫번째슬롯에 장착한 RX 560에 두개의 모니터 모두 출력이 되었고, 반대로 두번째슬롯에 장착한 1070 ti엔 어떤 모니터를 연결해도 아무런 반응이 없습니다.


     첫번째 슬롯을 우선 순위로 잡는거같은데 왜 이런 현상이 발생하는지는 모르겠습니다...


    설치에는 @ClimbJoe  님이 작성하신

    "[Success Guide]macOS High Sierra Version 10.13.2 – Coffee Lake Hackintosh – i7-8700k https://x86.co.kr/mymac/1975900 "를 따라했습니다.

    처음 설치만 unibeast를 이용해서 설치하고 이후에 SSD에 Climbjoe님의 EFI 폴더를 복사했습니다. 클로버 또한 가이드에 나온대로 최신으로 업데이트 했습니다.


    * EFI 폴더 또한 크게 다르지 않습니다. 시리얼넘버 정도만 수정했습니다. 

    * 엔비디아 웹드라이버는 WebDriver-387.10.10.10.30.103 버전 설치했습니다.



    혹시 커스텀맥 고수분들중에서 첫번째 슬롯에 1070 ti를 장착하고, 두번째 슬롯에 RX 560을 장착해서 RX 560으로만 듀얼모니터를 쓸 수 있는 방법을 알려주시면 감사하겠습니다...


    찾아보니 pci express 속도 x8과 x16이 크게 체감이 안된다곤 합니다만 그래도 해결해보고 싶은 문제입니다.



     


    #RX_560,#RX560,#라데온_RX_560,#GTX_1070_ti,#클로버,#듀얼모니터,#맥os,#찾아보니_pci_express_속도_x8

    댓글 22
    profile (40a3d2)
    달쇠
    18.04.13
    달쇠 @재댕

    dsdt 패치등을 이용하셔서 rx560 을 GFX0으로 바꿔보시는건 어떨까 합니다.


    저도 초보라서 이게 잘 될지는 모르겠네요.


    재댕
    18.04.13
    재댕 @달쇠

    답변감사합니다. 아직 초보라서 dsdt 패치같은걸 어떻게 해야되는지 잘 모르겠네요ㅠ, 좀더 공부가 필요한가 봅니다...


    profile (40a3d2)
    달쇠
    18.04.13
    달쇠 @재댕


    IORegistryExplorer 같은 유틸로 탐색을 해보세요.


    SMbios에 맞게 IGPU/GFX1 이런식으로 나와있는 부분을 본인이 원하는 순서에 맞게 조절하시면 될겁니다.

    팁 게시판에 zisqo님 글을 검색해보시는것도 좋을것 같습니다.



    물론 이게 해결책이 될지는 저도 잘 모르겠습니다.



    재댕
    18.04.13
    재댕 @달쇠

    친절하게 설명해주셔서 감사합니다ㅎ


    추가 - 그냥 첫번째슬롯에 1070 ti를 고집하지않고 두번째 슬롯에 1070 ti를 쓰기로 결정했습니다ㅎ; 위 방법을 도전해보진 않았습니다ㅠ


    profile (1daa00)
    AMStudio
    18.04.13
    AMStudio @재댕

    560과 1070ti를 맥에서 동시화면 출력 구현이 가능할까 싶습니다.  가능하다면...6~7 모니터를 동시 연결? 오오오오!!!!기본적으로 커맥은 유사하드웨어를 정품인것으로 속이는 것을 기본으로 하는데...어느정도 타협을 하심이....여하튼 파이팅입니다.


    profile (40a3d2)
    달쇠
    18.04.13
    달쇠 @AMStudio

    크로스파이어나 sli는 몰라도 그냥 다중 gpu는 가능할것 같네요.


    재댕
    18.04.13
    재댕 @AMStudio

    음 제가 원하는건 두번째 슬롯(x8)에 장착한 RX 560으로만 맥을 구동시키는 것이라 최대한 노력해봐야겠습니다ㅠ 사실상 1070 ti는 윈도우를 위해서만 쓸 생각이고 번거롭게 os를 바꿀 때마다 바꿔낄수는 없으니깐요ㅠ


    재댕
    18.04.13
    본인이 본인에게

    https://x86.co.kr/tip/1408613

    검색을 해보니 그냥 처음부터 두번째 슬롯에 메인 그래픽카드를 끼고 첫번째 슬롯에 부팅용 그래픽카드를 끼신분도 보이긴합니다.

    바이오스에서 Initial Display Output을 PCIe (RX 560이 장착된) 두번째 슬롯으로 바꿔보았으나 차이가 없네요ㅠ


    profile (9376f7)
    ClimbJoe
    18.04.13
    ClimbJoe @재댕

    쪽지 잘받았습니다 죄송합니다 좀바뻤습니다 ㅠㅠ

    일단 대단한 구성을 하셨다고 말씀드리고싶네요. 

    가능하시면 현재 EFI폴더를 그대로 보내주세요. 여기 첨부가 용량땜에 안될테니까 joe@climbjoe.tv로보내주세요



    재댕
    18.04.13
    재댕 @ClimbJoe

    아뇨 관심가져주셔서 감사합니다ㅠ 메일로 EFI 폴더 보냈습니다. 메일내용이랑 함께 봐주시면 정말 감사하겠습니다ㅠ


    profile (f8c213)
    lavapong
    18.04.13
    lavapong @재댕

    pci lane x8, x16 속도 차이에 목숨걸 필요가 없는게 평균 fps 기준 1 정도 차이 납니다.

    https://www.youtube.com/watch?v=XJuj16gRoBI

    본인 성격상 찝찝한건 못견디다 그런게 아니라면 그냥 주암부엔 세팅으로 써도 무난합니다.

    평균프레임 1은 60fps 넘게 유지되는 상황에서 어차피 체감이 안되죠.


    재댕
    18.04.13
    재댕 @lavapong

    진짜 체감하기도 힘든 차이네요ㅎ 그냥 이것저것 시도해보고 안되면 타협하고 쓰는수밖에 없을지도 모르겠습니다. 답변주셔서 감사해요ㅎ


    profile (9376f7)
    ClimbJoe
    18.04.14
    ClimbJoe @재댕

    재댕님이 커맥입문자시라 당연히 그렇겠지만, 시간이 지나보면 천천히 한개씩 고치고 싶으신게 보이실겁니다. 어제 보내드린 EFI는 눈에 띄는 부분을 수정한 것이라서 이제 그상태에서 안되는 기능들을 찾아서 고치시기만 하면됩니다. 예를 들어 기존 EFI에서는 퀵싱크가 안되고 있었고, 아이메시지 등등도 UUID를 넣었다고하더라도 되지 않았을 것입니다. 이전까진 쓰지않으셔서 모르셨을수 도 있으나 시간이 지나다보면 천천히 한개 씩 눈에 띄실거예요. ㅎㅎ

    그래도 찾아보시고, 본인이 먼저 시도해보시면서 모르는 부분을 자세히 설명해주시니까 도와드릴수 있는 여력이 있습니다. 다른 분들도 요런식으로만 적극적으로 질문하시면 좋을텐데 말이지요.


    재댕
    18.04.14
    재댕 @ClimbJoe

    감사합니다. 바쁘신 와중에도 도움주셔서 새벽에 이것저것 시도해보았는데요, 일단 어제 이메일로 보내주신 EFI폴더를 적용해보았습니다.

    1. 첫번째슬롯(1070ti), 두번째슬롯( RX 560)을 장착해서 시도하니 클로버화면 이후 애플로고 아래 로딩바에서 화면이 멈추는 문제 발생

    2. 위치를 바꾸어서 첫번째슬롯(RX 560), 두번째슬롯(1070ti)를 장착해서 시도해도 마찬가지 문제가 발생했습니다.

    3. 마지막으로 네이티브로 붙는 RX 560만을 가지고 첫번째 슬롯에 장착해보니 하이시에라 바탕화면까지 무사하게 부팅이 가능했습니다.

        하지만 아쉽게도 모든 USB포트가 작동하지 않아서 마우스, 키보드조차 사용이 불가능했습니다. (클로버 화면에선 키보드 마우스가 정상동작확인)


    사실 키보드같은 경우는 제가 커세어 K65 제품을 쓰고있는데 USB연결포트가 두개 필요해서 그런지 맥에서 쓸때는 간헐적으로 끊김이 발생했었습니다.

    근데 마우스까지 안되서 전 USB포트를 확인해보니 모두 다 인식을 못하고 있더라구요. 또 신기하게 키보드, 마우스, USB메모리에 불은 들어오는데 인식은 못합니다ㅎ 화면 우측상단위에 시계가 동작하는걸 봐선 프리징이 걸린건 아닌거같은데말이죠.


    결론적으로 말씀하신대로 제가 직접 하나하나씩 공부해가면서 쓸 수밖에 없는것 같습니다ㅎ 아직 현재진행형이니 완벽하진 않더라도 쓸 수 있는 수준까진 만들어서 후기 남겨볼게요ㅠ


    profile (9376f7)
    ClimbJoe
    18.04.14
    ClimbJoe @재댕

    제가 어제 실수를 했네요. 새벽에 하느라구요. ㅠㅠ 다시 이메일 보냈으니  그대로 EFI만 바꿔보세요. 불안하시면 일단, 제작하신 부팅 유에스비를 마운트 하신뒤, 거기 EFI를 통채로 바꾸시고 USB부팅하시면 기존 시스템은 안건드려도됩니다. 그리고 다 잘된다하시면 마지막에 교체하시면되요.


    profile (540b94)
    뉴해킨
    18.04.14
    뉴해킨 @재댕

    native로 지원되는 그래픽 카드로 설치 하시면 가능할것 같군요. 제가 오래전에 AMD 6850과 Nvidia GTX580으로 각각 2개씩 모니터 4개를 사용했었습니다.  물론 os x상에서요. 두 모델 모두 graphic injection이나 웹드라이버같은 3rd party도움을 받지 않는 모델들이었구요..  AMD560은 기본적으로 지원되니까 Nvidia를 760같은것으로 넣고 테스트를 시작해 보시는것이 좋을듯 해 보입니다.  그런데 윈도우에서 부팅이 가능할까요?


    재댕
    18.04.14
    재댕 @뉴해킨

    1. 네이티브로 바로 인식되는 엔비디아, 라데온 그래픽카드 두개를 쓰면 해결될지도 모른다고 생각합니다만, 1070 ti를 사용하는 이유가 윈도우10 게이밍환경에서도 부족하지 않는 사양을 원하기 때문이거든요ㅠ 엔비디아 500번대나 600번대 그래픽카드로 최신 3D 게임을 즐기기엔 무리라서 힘들겠네요ㅠ 답변은 감사합니다ㅎ 

    2. 그리고 현재 윈도우10 기준으로는 첫번째 두번째슬롯에 라데온, 엔비디아 그래픽카드 조합을 써도 (첫번째, 두번째슬롯을 바꾸어서 사용해도) 전혀 문제가 없습니다. 다만 엔비디아 카드는 바로 드라이버 설치까지 자동으로 진행되어 사용가능했지만, 라데온 그래픽카드 같은 경우는 수동으로 드라이버를 설치해서 사용해야 했습니다.


    profile (9376f7)
    ClimbJoe
    18.04.14
    ClimbJoe @재댕

    두개 카드를 꽂아서 성공할수 있을지는 모르겠습니다. 제가 상식적으로 알고 있기는 부팅불가였는데,,된다고 하시니, 시도해보세요. 내장그래픽은 일단 활성화 시키시고 시도해보세요. 커널패닉이 날경우 내장은 Disabled해보시구요. 라데온카드있으시니 별로 필요없을 것 같습니다. 


    재댕
    18.04.14
    재댕 @ClimbJoe

    새로 보내주신 EFI폴더로 적용해보았으나 마찬가지로 USB쪽에서 문제가 있는 것 같습니다. 하이시에라 부팅이후 마우스, 키보드가 작동을 안하네요...


    profile (9376f7)
    ClimbJoe
    18.04.14
    ClimbJoe @재댕

    음,,이상하네요. SSDT적용하신것도 아닐테고, 8700k는 네이티브로 붙을텐데요...음 그러시면 켁스트폴더에서USBinjectAll.kext 제거 하시고 해보세요. 


    재댕
    18.04.14
    재댕 @ClimbJoe

    USBinjectAll.kext 제거하고 다시 해봐도 동일증상이었습니다.

    삭제한 USBinjectAll.kext는 원상복구하고 기존에 부팅이 가능했던 config.plist 파일이랑 이메일로 보내주신 config.plist를 하나씩 비교해보았습니다.

    보내주신 config.plist파일에서 바뀐것들이 어떤 기능을 하는지 아직 초보라서 잘 모르겠는데, Devices 섹션에 USB 탭을 보니 Inject, Add ClockID, FixOwnership, HighCurrent 4개 전부다 체크해제가 되어있었습니다.

    혹시 이게 문제인가 싶어서 아래 사진과 같이 4개 전부체크하고 부팅해보니 키보드, 마우스 전부 정상작동 가능해졌습니다.

    (아 그리고 기존 부팅 가능했던 config.plist 같은 경우엔 HighCurrent 빼고 3개가 체크되어있었습니다. 제 커세어 k65 키보드가 간헐적으로 인식이 안되던게 HighCurrent를 체크 안한게 문제일지도 모른다고 생각해서 체크해보았습니다.)



    재댕
    18.04.14
    재댕 @ClimbJoe

    사운드도 안들려서 기존에 가지고 있던 config.plist랑 최대한 비슷하게 아래와 같이 체크하니 사운드도 정상작동합니다.




    댓글 쓰기 권한이 없습니다.
  • 다음글 설치 시, 무한 재부팅 [20]
  • 이전글 ALC892에서 마이크 출력이 스피커로 안되네요 [6]
  • 커스텀맥 만능질문 - QA | 커스텀맥 Q&A

    날짜 제목 글쓴이 조회 수
    17.07.30 데탑 모니터(오류화면) 사진 찍을 때 팁(소소함) 달쇠 6318
    17.02.10 데탑 답변을 쉽게 받기 위한 팁 / 기본 규칙 / 답변에 회신필수 / EFI폴더 압축법 Mactopia 7664
    18.04.18 데탑 이부분부터 진행이 안됩니다 dryice 271
    18.04.18 데탑 메버릭스 10.9.5 GTX750ti 그래픽카드 부팅실패 miraip 260
    18.04.18 데탑 warning: inode_val: object (oid 0x150eaf): invalid bsd_flags (0x184) 글쎄다 166
    18.04.18 데탑 썬더볼트 메인보드 한방에 붙는 모델 추천좀 해주세요 cts 345
    18.04.18 랩탑 한성 a36x 고스트 진행중 acpi 에러 메세지로 진행이 되지 않아 질문 드립니다. 디동라리 215
    18.04.18 데탑 오디오인터페이스 관련 썬더볼트 질문입니다. cts 200
    18.04.18 데탑 MSI MSI GP72MVR Leopard Pro/GTX1060 듀얼 맥 설치 ㅠㅠㅠ personkr1 233
    18.04.18 데탑 하이시에라 설치질문입니다 권태윤 274
    18.04.18 데탑 pc 사양 문의 mr03 378
    18.04.17 데탑 커피레이크에서 요세미티 설치가능여부 맥키601 229
    18.04.17 데탑 해킨 초보입니다. 귀엘 139
    18.04.17 데탑 하이시에라 설치 에러문의 곰네마리가족 339
    18.04.17 데탑 제 컴퓨터 사양인데 설치가 가능할까요~? 서퍼 274
    18.04.17 데탑 10.9 Mavericks 를 설치하려고 합니다. +캡쳐추가 miraip 304
    18.04.16 데탑 맥에서 오디오 하드웨어가 뭔지 어떻게 알수 있을까요? 월드 383
    18.04.16 데탑 Unknown 프로세서 이름 변경, 이 맥에 관하여 변경이 안됩니다. 재댕 403
    18.04.16 데탑 wifi 블투 모듈을 구입하려고 하는데 제 목적에 이 제품이 맞을까요? 호라이즌제로던 372
    18.04.16 데탑 MBR missing--MBR 패치후 클로버 화면이 안뜨고 커서 하나만 계속나옵니다 용인사람 275
    18.04.16 데탑 설치 usb생성중 오류문구발생 김뚱꼬 94
    18.04.16 데탑 제 하드웨어에 맞는 메인보드 추천해주실수 있을까요? 귀엘 190
    18.04.15 데탑 랜 카드가 도저히 잡히지 않습니다 asa3513 205
    18.04.15 데탑 GTX 1070 Ti 정상설치하신분 계신가요? NamuOh 390
    18.04.15 데탑 어제만해도 잘되다가 갑자기 부팅이 안됩니다 ㅠㅠ 재현파크 253
    18.04.15 데탑 해킨에서 강제로 윈도 디스크들을 초기화 시켰더니 윈도도 날라가고 초기화도 제... CHUN 185
    18.04.15 데탑 웹드라이버를 설치했으나 적용이 안됩니다! 월드 399
    18.04.15 데탑 지긋지긋하시겠지만 +++++오류 한번만 봐주십시오 ㅜㅜ h110m-ds2v 기가바이트이 닉네임86 366
    18.04.15 데탑 설치 진행이 안됩니다. 현월 192
    18.04.14 데탑 서피스랩탑에 하이시에라 설치했는데 무슨짓을 해도 키보드가 인식이 안됩니다.. 쑤등 311
    18.04.14 데탑 Clover를 USB에 설치하면 SSD가 보이지 않네요. 스톤콜드 205
    18.04.14 데탑 멀티부팅 질문 Tonik 235
    18.04.14 데탑 해킨토시 속도가 너무느려요.. canata 341
    18.04.14 데탑 이 사양이면 해킨토시 USB만들어서 설치할수 있나요? 중고딩호나우딩요 373
    18.04.14 데탑 웹드라이버 제거 방법 하느신 221
    18.04.14 데탑 디스크오류 시에라맥초보 133
    18.04.14 데탑 nada_drv=1 적용 시 부팅 오류 현상 질문드립니다. wdkdwko 234
    18.04.14 데탑 GUI로안너어감 Riu2018 178
    18.04.14 데탑 그놈의 재부팅 ++ Riu2018 428
    18.04.14 데탑 does printf work?? conkit 338
    18.04.14 데탑 "installation requires downloading important content.....(설치를 계속하... 재현파크 309
    18.04.13 데탑 하이시에라 부팅 시간이 너무 오래걸리는데 왜그런건가요? 월드 436
    18.04.13 데탑 ALC892에서 마이크 출력이 스피커로 안되네요 거누 242
    데탑 엔비디아, 라데온 이중 구성시 문제가 있습니다. 재댕 415
    18.04.13 데탑 설치 시, 무한 재부팅 요잇호잇 558
    18.04.13 데탑 Reboot and selcet proper boot device or insert boot media... -1 마크투 210
    18.04.12 데탑 맥 설치중..사과로고 뜨고 재부팅.. -1 conkit 464
    18.04.12 데탑 개발하시는 분들 맥북이랑 커맥 있으시면 코드관리 어떻게하세요? 루이스 296
    18.04.12 랩탑 [High Sierra 10.13.4] 업데이트 후 검은화면 삽질 질문입니다~ 별님 700
    18.04.11 랩탑 노트북 트랙패드를 마우스로 인식하는 증상 해결법좀 별초롱이 397
    18.04.11 데탑 업데이트 후 부팅 안되요 ㅠ mac초보 300
    18.04.11 데탑 라이젠 시스템 10.12 설치 후 kextcache및 부팅 불가 문제 킹짭이 218
    1 - 36 - 206
    서버에 요청 중입니다. 잠시만 기다려 주십시오...